Scheduled for September 19, 2025 at 3:00 AM – 4:00 AM
Affects
Dashboard
Under maintenance from 3:00 AM to 4:00 AM
API Service
Under maintenance from 3:00 AM to 4:00 AM
Insight
Under maintenance from 3:00 AM to 4:00 AM
Updates
Completed
September 19, 2025 at 4:00 AM
Completed
September 19, 2025 at 4:00 AM
Maintenance has completed successfully
In progress
September 19, 2025 at 3:00 AM
In progress
September 19, 2025 at 3:00 AM
Maintenance is now in progress
Planned
September 19, 2025 at 3:00 AM
Planned
September 19, 2025 at 3:00 AM
We are planning for a scheduled maintenance during that time.
Scope of Changes:
Platform Console
Platform Core Service
Edge Software releases
UI/UX Updates
Improvement Week: Enhancing the Usability of EIP, SSL Certificates, and Cache Sharding
We are pleased to announce that this week's updates focus on several key feature optimizations and bug fixes. We're also laying the groundwork for significant new features in the next phase.
✨ This Week's Updates ✨
New Features
Edge Deployment: Edge deployments on non-mainstream cloud providers now support automatic collection and reporting of EIP addresses. In most cases, manual configuration is no longer required, although you can still manually modify them as needed.
Improvements
Resources: The resource list now displays the validity status of the SSL certificate associated with a domain, providing a quick overview of certificate configurations.
Cache Control Plugin: The cache sharding feature is now enabled by default to simplify configuration. We have also added new operational guidance to make it easier to configure caching for large files and streaming media.
Dashboard: We've optimized the page display for several entity reports.
UI/UX: Various improvements have been made to user interactions and operational guidance.
Bug Fixes
Edge: Addressed known crashes, exceptions, and security vulnerabilities.
Cache: Fixed a bug where cache duration settings would fail in a few specific scenarios.
DNS Routing: Resolved several synchronization errors with DNS service providers.
Fixed an issue where the tenant name was displayed incorrectly in alert emails.