Scheduled for September 11, 2025 at 8:00 AM – 10:00 AM
Affects
Dashboard
Under maintenance from 8:00 AM to 10:00 AM
API Service
Under maintenance from 8:00 AM to 10:00 AM
Insight
Under maintenance from 8:00 AM to 10:00 AM
Logs Streaming
Under maintenance from 8:00 AM to 10:00 AM
Updates
Completed
September 11, 2025 at 10:00 AM
Completed
September 11, 2025 at 10:00 AM
Maintenance has completed successfully
In progress
September 11, 2025 at 8:00 AM
In progress
September 11, 2025 at 8:00 AM
Maintenance is now in progress
Planned
September 11, 2025 at 8:00 AM
Planned
September 11, 2025 at 8:00 AM
We are planning for a scheduled maintenance during that time.
Scope of Changes:
Platform Console
Platform Core Service
Edge Software releases
UI/UX Updates
✨ New Feature
Upstream Authentication
The edge can automatically inject authentication credentials into upstream requests, reducing the risk of key leaks and improving operational efficiency.
🔧 Improvements
DNS Routing
Enhanced integration with DNS providers and improved domain routing logic for a more natural workflow.
Advanced Certificate Management
Achieved more automated certificate issuance and renewal by combining HTTP validation and DNS validation with DNS provider integration.
Dashboards & Plugins
Optimized data analysis and visualization across multiple plugins.
UI/UX
Clearer feature descriptions and more intuitive operation guidance.
🐞 Fixes
Edge: Stability, crash, and security fixes.
SSL/TLS Settings: Corrected HTTP-to-HTTPS redirect status codes.
Cache Control: Fixed parameter issues in default caching rules.
Advanced Certificate Management: Resolved wildcard certificate extraction failures on Windows.
Request & Response Rewrite: Corrected wildcard rewrite logic when no matches were found.