Platform Core Services & Edge Software Scheduled Maintenance
Scheduled for September 04, 2025 at 8:00 AM – 10:00 AM
Affects
Dashboard
Under maintenance from 8:00 AM to 10:00 AM
API Service
Under maintenance from 8:00 AM to 10:00 AM
Insight
Under maintenance from 8:00 AM to 10:00 AM
Completed
September 04, 2025 at 10:00 AMCompleted
September 04, 2025 at 10:00 AMMaintenance has completed successfully
In progress
September 04, 2025 at 8:00 AMIn progress
September 04, 2025 at 8:00 AMMaintenance is now in progress
Planned
September 04, 2025 at 8:00 AMPlanned
September 04, 2025 at 8:00 AMWe are planning for a scheduled maintenance during that time.
Scope of Changes:
Platform Console
Platform Core Service
Edge Software releases
UI/UX Updates
New Features
Improvements
Edge: Error messages for failed edge installations are now more specific.
Content Compression Plugin: Adapted to handle origin compression behavior in some scenarios.
Certificate Management Plugin: Fixed issues with certificate renewal failures and duplicate renewals in certain situations.
Edge Probing plugin: The insights feature now includes detailed statistics for each probe type, providing more intuitive and comprehensive results.
Resources: Removed proxy types to make resource definition simpler and clearer.
UI/UX: Various information and interaction optimizations to make feature descriptions and operational guides clearer.
Fixes
Edge: Known crashes, exceptions, and security fixes.
Access Log Plugin: Fixed an issue where custom log formats were not working.
Tenant Console: Resolved the problem of frequent "Network Error" messages.