Platform Services & Edge Software Scheduled Maintenance
Scheduled for March 27, 2026 at 6:00 AM – 8:00 AM
Affects
Dashboard
Under maintenance from 6:00 AM to 8:00 AM
Configuration Management
Under maintenance from 6:00 AM to 8:00 AM
API Service
Under maintenance from 6:00 AM to 8:00 AM
Insight
Under maintenance from 6:00 AM to 8:00 AM
Completed
March 27, 2026 at 8:00 AMCompleted
March 27, 2026 at 8:00 AMMaintenance has completed successfully
In progress
March 27, 2026 at 6:00 AMIn progress
March 27, 2026 at 6:00 AMMaintenance is now in progress
Planned
March 27, 2026 at 6:00 AMPlanned
March 27, 2026 at 6:00 AMWe have scheduled an upgrade maintenance, which will take approximately 2 hours. During this period, related services may be temporarily unavailable.
Edge Version Info
New Features
Rate limiting plugin: Added a Challenge action to trigger interactive verification for excessively frequent requests.
Rate limiting plugin: Added rule insights, including per-domain throttling effectiveness and attack sources, plus auditing of blocked IP addresses.
Improvements
UI/UX: Improved bilingual (Chinese/English) descriptions and onboarding for features.
Rate limiting / General ACL plugins: Added rule match logs in Insights for faster verification of rule matches and triggers.
Fixes
Issues with partial edge node installation failures, process crashes, and caching.
Certificate issuance failures in some scenarios.
Missing statistics from the rate limiting plugin under high concurrency.