Scheduled for October 10, 2025 at 7:00 AM – October 11, 2025 at 9:00 AM
Affects
Dashboard
Under maintenance from 7:00 AM to 9:00 AM
API Service
Under maintenance from 7:00 AM to 9:00 AM
Insight
Under maintenance from 7:00 AM to 9:00 AM
Installer Service
Under maintenance from 7:00 AM to 9:00 AM
Updates
Completed
October 11, 2025 at 9:00 AM
Completed
October 11, 2025 at 9:00 AM
Maintenance has completed successfully.
In progress
October 11, 2025 at 7:00 AM
In progress
October 11, 2025 at 7:00 AM
Maintenance is now in progress
Planned
October 10, 2025 at 7:00 AM
Planned
October 10, 2025 at 7:00 AM
We have scheduled an upgrade maintenance, which will take approximately 2 hours. During this period, related services may be temporarily unavailable.
New Features
DNS Routing Plugin: Supports CNAME record type.
Improvements
Edge: Continued enhancement of reliability, optimizing log output, sampling, and event output logic.
DNS Routing: Optimized the configuration interaction experience for its Geo and ISP.
Advanced Certificate Management: Optimized information on the certificate list and detail pages; supports manual certificate applications that can be linked with DNS Integration for automatic validation.
Cache Control: Defaults to caching file name suffixes and segments; optimized caching based on status codes; defaults to segment caching.
Custom Error Pages: Adjusted to default to displaying the origin server's page for origin/backend exception status codes.
Event Logs: Added new fields to support richer log recording and event retrieval.
Insight Log Explorer: Added descriptions for query conditions and new commonly used fields.
UI/UX: Several interaction and operation guide improvements.